Swisslog's Forum
SWISSLOG & WSJT-X & WSJT-X - JTAlertX - Printable Version

+- Swisslog's Forum (https://www.swisslogforwindows.com/forum)
+-- Forum: Swisslog version 5.x (https://www.swisslogforwindows.com/forum/forumdisplay.php?fid=3)
+--- Forum: General discussion (https://www.swisslogforwindows.com/forum/forumdisplay.php?fid=4)
+--- Thread: SWISSLOG & WSJT-X & WSJT-X - JTAlertX (/showthread.php?tid=612)



SWISSLOG & WSJT-X & WSJT-X - JTAlertX - SV2DGH - 24-07-2019

Hi Jordi,

I'm running SWISSLOG 5.99b with WSJT-X v2.1.0. Both programs run fine and each qso of ft8 is added automatically to swisslog log, and all details of the qso are updated correctly to the swisslog database.

I also run wsjt-x v2.1.0 and  JTAlertX v2.13.10. Both programs run fine too, communicate with each other and each callsing  alert is added to wsjt-x to be qso.

Now I try to run simultaneously swisslog 5.99b, wsjt-x v2.1.0 and  JTAlertX v2.13.10.  Unfortunately JTAlert doesn’t show any alert,  but instead it pops up a fault message about  udp port and ip address being invalid and unable to communicate with each other.

My question is as follows : since swisslog is working with wsjt-x,   wsjt-x is working with jtalert,  then maybe the problem is the function and utilization  of the 3 programs swisslog,  wsjt-x & jtalert at the same time ?   
Do you have any idea how it can be solved ?

Thanks in advance
Chris SV2DGH


RE: SWISSLOG & WSJT-X & WSJT-X - JTAlertX - EA3GCV - 24-07-2019

Hi Chris,

The set up for WSJT-X / JTDX and JT Alert is explained in the Digital Modes Interfaces > WSJT-X / JTDx Operation in the Swisslog help:

https://www.swisslogforwindows.com/english/Help/Features/HamScope%20Support.htm#WSJT

There is a very highlighted note for JT Alert users. When using JT Alert, you have to do the following:

- In JTALERT go to Settings > Manage Settings > Applications > WSJT-X then check the Rebroadcast WSJT-X UDP Packets (received only) option with the default option through port 2334 (this is ok in your configuration, according your attached screenshots). Uncheck the Enable transmission of last QSO in Last QSO API through port 2333 unless you really need it for other application.
- However, I guess you have not set this port in Swisslog. So go to Options | Digital Modes-Interface | WSJT-X / JTDX | UDP Settings and set the same settings defined in JT Alert (127.0.0.1 and port 2334).

Now WSJT-X and JT Alert will communicate each other through port 2337 (the default port) and JT Alert will rebroadcast UDP packets to Swisslog through port 2334, so 3 programs will be working together without any conflicts.

Best 73


RE: SWISSLOG & WSJT-X & WSJT-X - JTAlertX - SV2DGH - 24-07-2019

Dear Jordi
I have just followed your instructions and indeed, the 3 programs are working together perfectly now.
Thank you very much for your quick and kind response, as well as your presice instructions.
Al the best, 73
Chris SV2DGH